Elevated Latency and Partial Service Impact

Incident Report for Medeloop

Resolved

The issue causing elevated latencies and intermittent disruptions has been resolved. All systems are now operating normally.

We have confirmed stability across the platform and will continue to monitor performance to ensure full recovery.
Posted Oct 21, 2025 - 16:06 UTC

Investigating

We are currently investigating elevated latencies and intermittent disruptions affecting parts of the platform. Some users may experience slower response times or delayed on our platform.

Our engineering team is actively investigating and working on mitigation steps to stabilize the platform. We’ll continue to provide updates as recovery progresses.
Posted Oct 20, 2025 - 16:30 UTC
This incident affected: Web Apps (Researcher Web App, Account Web App).